Browser libqgenericbearer.so error

Forum thread started by paulfxh on Mon, 2010-12-13 14:08

I've seen some very good reports of the Arora browser in a recent post to this forum and in another to Haikuware. However, when I tried out Arora 0.11.0 in both R1A2 and r39792, although there's a lot to like about it, on my computer it crashes so frequently as to be almost unusable.
Yet the first of the above links rates it as being "stable".
When it crashes, in either R1A2 or r39792, the debugger invariably provides the following as the final part of the output:
Loaded symbols for /boot/common/add-ons/Qt/plugins/bearer/libqgenericbearer.so [tcsetpgrp failed in terminal_inferior: Invalid Argument]
I also tried Arora 0.10.2 in r39792 and this crashed just as frequently with the same gdb output.
Additionally, the QtWeb browser gave the same performance and gdb information when I ran it in r39792.
Perhaps I'm missing an essential library?
Anybody know what might be the problem here?

Comments

Re: Browser libqgenericbearer.so error

Arora 10.2 was very stable on Haiku when I tested it awhile back.

Recalling your post from here:
http://www.haiku-os.org/community/forum/how_copy_graphics_driver_nightly...

Sounds like you may have file system corruption. Run checkfs in terminal - look at available command options before running.

1) checkfs may repair damage to your file system. 2) *Re-initializing the partition* and re-installing Haiku will fix any file system errors in case checkfs fails. The 2nd option will wipe out everything from your Haiku partition but better choice because ensures your system files have not been corrupted.

Re: Browser libqgenericbearer.so error

Thank you for your reply.
You are correct that I had some problems in R1A2. However, before trying out Arora 0.11.0, I had "clean"-reinstalled R1A2 i.e. I initialized the partition before the install.
Now checkfs shows the filesystem as being clean.
Nevertheless, the problems with Arora persist. I think I'll need to identify with more precision what operations preceed the crash. But, certainly, a lot of the crashes occur when I try to create a new bookmark.

My r39792 install did, however, have some fs corruption. But after receiving your reply I clean-installed r39825. Nevertheless, Arora 0.11.0 still crashes with an alarming frequency with the very same libqgenericbearer.so notification in the gdb.

I believe my problem is Qt-related as Web+ works perfectly but Arora 0.10.2 or Arora 0.11.0 or QtWeb all crash with the same libqgenericbearer.so reference.

Re: Browser libqgenericbearer.so error

Ok, checking your file system was a good first step.

Next, Qt libraries and Arora are compiled on a certain version of Haiku. Using a different version of Haiku may or may not work. Sometimes development changes occur to the OS which could be causing your crashing. I never tried bookmarks so don't know if that was working or not.

You can 1) try same or close to version of Haiku that Qt/Arora was compiled on 2) provide debug info ( type bt when crashes & copy output - should file a ticket with it ) 3) compile Qt & Arora on Haiku revision you're using (kinda difficult - only for experts).

Very few people here to help you out. You may want to ask on Haikuware or Haiku general mailing list.

Re: Browser libqgenericbearer.so error

Thanks again for your reply.
Yes, I believe my problem relates to Qt so I think I'll try compiling it tomorrow.
I should mention that to get Arora 0.11.0 to launch at all in R1A2, I had to uninstall the "native" Qt and reinstall it from SPM.
I've also installed Qt 4.7.1 (minimal) from qt.haiku.ru into R1A2 and with this, again Arora failed to launch and gave a "Missing Symbol" error message.
I did actually provide the essential part of the debug info I got after a crash in my first post to this thread.
Nevertheless, given that I'm using either R1A2 or a very recent nightly with Arora, hardly anything very out of the ordinary, I would be surprised if this problem was unique to me. So, I'm puzzled why nobody else has reported the same difficulty.

Re: Browser libqgenericbearer.so error

i've been having these crashes for sometime now,i even tested these browsers with the latest revisions & latest qt 4.8.same result.
arora,qtwheb,dooble browser,weilteinweiter?? all of these are qt dependent and they all crashes,so i gave up using them.

Re: Browser libqgenericbearer.so error

@khallebal
Glad to hear that this problem is not unique to just me.

I tried out tonestone57's suggestion and compiled/installed Qt 4.7.1 in Nightly r39848 ggc4hybrid.
However, I was unable to compile Arora 0.11.0.
Nevertheless, after installing Arora 0.11.0 from SPM, although it still crashes, it seems at least moderately more stable than it was before.
When it does crash, according to the gdb, it seems to do so after loading libqgenericbearer.so just as before.
However, at least now I'm able to do some reasonable browsing without crashes. Also, I'm writing this post from Arora in r39848 which would have been unthinkable before.
So, this is by no means a complete solution but at least the Arora browser is usable now.
Incidentally, I briefly tried QtWeb after compiling Qt 4.7.1 in r39848 but it crashed very soon after launch.