Wireless conection with static IP and WEP

Forum thread started by pepito1 on Sun, 2011-01-23 21:34

Hello! I'm trying to configure my Wireless conection. I have an Intel 5100 wireless card (it's detected and uses the Intel 4965 driver). How can I configure it with a static IP and with WEP?


Re: Wireless conection with static IP and WEP

I tried it, but I can't connect to the Internet. I introduce the IP, gateway, etc in Network and then I use the command "ifconfig /dev/net/iprowifi3945/0 join wifitopia mypassword" (replacing driver, network and password, of course) but I continue without connection. When I write ping www.google.com in terminal it gives me an error that it didn't found the server.

What can I do?

Re: Wireless conection with static IP and WEP

Which version of Haiku? Check if you also have setwep in your Haiku. If you have setwep then you must use that instead.

You sure your network is WEP & not WPA?

Can you ping your router (gateway)? If no, you're not connecting to router for different reasons. If yes, then you have DNS issue.

If newer Haiku do:
ifconfig /dev/net/iprowifi3945/0 list
*change iprowifi3945/0 to what yours is (in terminal, start from /dev/net and go through the folders)

Re: Wireless conection with static IP and WEP

I'm using a nightly build and ifconfig (I tried R2 but it didn't recognise my wireless card. I'm sure it's WEP. I don't know what's "ping my router" but DNS are corect because I use the same in Windows. I see my connection and I followed the steps to put the WEP key but I don't know how to put the Ip, mask,etc. (I put them in Network, but it doesn't work.

How can I connect to the Internet?

Re: Wireless conection with static IP and WEP


I too have this issue. If i OPEN my network with NO SECURITY i can get into
my network, on the internet, use installoptionalpackage, get good ping results
from my router, etc. As soon as i reset the router to WEP settings i get nothing
at all.

I have tried these solutions that are posted in the forum but nothing works!

I tried the (/boot/common/settings/network/wireless_networks) trick and

network mynetwork {
password mypassword
as per instructions and nothing changes.

If i use Terminal and do -> ifconfig /dev/net/atheroswifi/0 list (or anything else)
then all i get is a bunch of instructions on commands that work in ifconfig.

So, like some of the others i am becoming frustrated. Anyone have any new ideas?
If so i am ALL EARS! (or eyes)

Thanks in advance! (just in case)

I like Haiku BeOS but must have access to my network and internet.

Re: Wireless conection with static IP and WEP

what version of Haiku? Try setwep in terminal. Haiku used setwep first and later changed to different method.

Your network device might be different from atheroswifi. In terminal, ls /dev/net & subfolders. What is your network card? listdev in terminal & copy info for network card.

Are you using or have you tried with 64 or 128 bit WEP?

Re: Wireless conection with static IP and WEP

The latest public information on the state of wireless networking in haiku is in this forum post by Axel. My reading of the situation is that he was getting along fairly well but, ran into the issue of how to safely store passwords/passkeys. Since this is a security issue that affects more than just networking, it appears that Axel has decided to work on a "password roster API" with a view to using it in his wireless implementation.

For now, I only intend to implement the basic services needed to make it work as far as I need it for the network stuff. The rest will grow over time.

My sense is that full wireless access is really close to becoming a reality. It's just that all the pre-requisites have to be met like how do you safely store encryption keys for commonly accessed networks?

Sorry for going of a bit there but I guess what I'm saying is, with the recent hectic pace of development in wireless access, all the available documentation might be out of date.


Re: Wireless conection with static IP and WEP

Since this thread kind of died out i thought
i should stir the pot a little bit here.

Yes i know about setwep and t