Disable swap?

Forum thread started by xvedejas on Sun, 2011-06-26 07:40

I'm running Haiku installed to a USB drive (2GB) and it looks like swap space is taking up a whole gigabyte of this, leaving me with around 200MB of free space. Is it possible to disable swap to disk?

Comments

Re: Disable swap?

xvedejas wrote:

Is it possible to disable swap to disk?

Yes. It can be done via the VirtualMemory preferences.

http://haiku-os.org/docs/userguide/en/preferences/virtualmemory.html

Re: Disable swap?

The virtual memory preferences show that virtual memory is disabled; but the diskUsage application shows that /boot/common/var/swap is taking up a big portion of disk space.

Re: Disable swap?

I've seen this problem a lot on my EeePC 901.
You need to just delete the swap file and then run checkfs on your Haiku partition.
If your partition is called haiku, run
checkfs /haiku

Re: Disable swap?

See these tickets (bugs) for info:
http://dev.haiku-os.org/ticket/7742
http://dev.haiku-os.org/ticket/7550

Setting appears to be ignored. Fairly sure turning swap off worked right awhile back ago.

swap file is found under:
/boot/common/var/

Turn off virtual memory in Preferences, reboot, delete swap file & run checkfs to get space back.