ipro1000 under BeOS Max?

Forum thread started by j_freeman on Wed, 2007-02-21 18:55

Been trying to get an R5 box up and running, but for the life of me I can't get it networked (surprise?). The D-Link, which has an RTL8139 chipset, doesn't want to work for some reason, although it has before. I tried the various drivers on BeBits with no luck. But I digress...

I've got Max installed in VMware, but I can't get the ipro1000 Haiku driver to work with it. Do I need to build it with a target of R5, or can I just use the Haiku binary?

Comments

BONE or net_server?

I think BONE comes with a newer RTL8139 driver... and doesn't require the funky net_server add-ons for each driver.

I think you may have to change the target when compiling ipro1000 for R5 - but I don't know the details of that.

ipro1000 driver

Issue #1
You can build the RTL8139 driver with R5 target. That should get your D-Link to work in MAX. (Haiku RTL8139 supports D-Links with Device IDs of 0x1300, 0x1301, 0x1340)

Issue #2
Sounds like you want to network through Vmware. If so, you need to install "vlance" driver (ethernet driver for Vmware).

Actually, running the

Actually, running the ipro1000 driver in VMWare should work fine (it has historically worked well for Haiku) - you only need to change the .vmx file to emulate "e1000" instead. (I guess I didn't think of that earlier)

On the other hand, the vlance driver may be easier to obtain and install from bebits.

I'll try giving BONE a whirl

I'll try giving BONE a whirl on my real hardware before I order some new NICs.

Oh, I wasn't aware there was

Oh, I wasn't aware there was a Vlance driver for R5. The only reason I was trying the ipro is because I know that works great under Haiku.

I'll try the vlance tonight, and if that doesn't work I'll try building the ipro for R5.

Well, I've got the RTL8139

Well, I've got the RTL8139 R5 driver (several variations in fact), so that's not the problem. It just doesn't seem to want to work with my card, which it has in the past. I'm thinking maybe it's the motherboard.

RTL8139

Check BIOS
#1 make sure "Plug & Play OS" is disabled
#2 make sure an IRQ is being assigned to the network card.

Also, you can try different pci slots & see if that makes a difference.

Check in BeOS to see if it is being detected (if it shows up in networking).

I tried different slots, but

I tried different slots, but I didn't think about IRQ or Plug & Play OS settings. Thanks for the tips.

Anyway, I did manage to get the vlance driver working in VMware/Max! :) Thanks guys for helping me with that.

So I decided to try and get

So I decided to try and get networking going on real hardware under Max. I tried a different card, a D-Link DL10038D (RTL8139), which shows up in the PCI devices with an ID of 0x1300. I applied the DFE-538TX patch, which is known to work with this card.

It shows up in Networking as RTL8139, so I give a hostname, set the DNS to my router IP, set the gateway, subnet, and IP addresses. When I open Firefox, it just keeps "looking up" whatever I type in.

I try pinging my router, but there's no output. I saw the card blink a couple of times, but nothing happens.

Any ideas? Tried restarting several times. I have PNP OS disabled, and there are no conflicts reported under Devices.

Try This:

The Haiku driver supports the Dlink 0x1300. You *should* be able to get an R5 build from the Build Factory.

http://factory.haiku-os.org/packages/haiku-rtl8139-cvs.zip

Ok, try the following, & if it don't work, then try with Haiku R5 driver.

Check for IRQ sharing with other network devices (does network card have same irq as other device?).

Check that the driver is in the right directory & you have a symbolic link to it.

Driver in:
/boot/beos/system/add-ons/kernel/drivers/bin

Symbolic link (to above driver) in:
/boot/beos/system/add-ons/kernel/drivers/dev/net

Did you patch the driver properly or patch the right driver?

Have you checked that you are entering in the right router ip (gateway)?

1) Enter in Static IP
2) Enter in Gateway (very important)
3) Netmask: 255.255.255.0
4) Better to use actual DNS servers (this won't affect pinging the router, but could affect getting internet traffic past the router).

That is all I could think of. You could also try other pci slots, but the device is showing up in BeOS, so that tells me that either the driver isn't recognizing it or it isn't configured right (or even a conflict?).

tonestone57 wrote: The

tonestone57 wrote:

The Haiku driver supports the Dlink 0x1300. You *should* be able to get an R5 build from the Build Factory.

http://factory.haiku-os.org/packages/haiku-rtl8139-cvs.zip

Installed it, replacing BeOS Max's driver. Upon rebooting, I now get a 'cannot initialize device' error.

Quote:

Check for IRQ sharing with other network devices (does network card have same irq as other device?).

Stupid question, but how can I check for IRQ sharing? There aren't any other Ethernet devices listed in Devices, but who knows.

Quote:

Check that the driver is in the right directory & you have a symbolic link to it.

Driver in:
/boot/beos/system/add-ons/kernel/drivers/bin

Symbolic link (to above driver) in:
/boot/beos/system/add-ons/kernel/drivers/dev/net

Did you patch the driver properly or patch the right driver?

Yup and yup. The driver was preinstalled (BeOS Max) and the patch was automated with an install script. It showed up in the Networking preflet after a reboot, just like it has in the past.

Quote:

Have you checked that you are entering in the right router ip (gateway)?

1) Enter in Static IP
2) Enter in Gateway (very important)
3) Netmask: 255.255.255.0
4) Better to use actual DNS servers (this won't affect pinging the router, but could affect getting internet traffic past the router).

Yeah, I've doubled-checked and triple-checked.

I think it's this motherboard. I've had problems in the past on non-BeOS machines. I'm going to try my Athlon XP board and chip when I get some time.

Thanks for trying to help, but I think I'm going to have to throw in the towel on this one. ;)

OK, Using Another System May Bring You Success

j_freeman wrote:

Installed it, replacing BeOS Max's driver. Upon rebooting, I now get a 'cannot initialize device' error.

I believe there was a recent post on here saying that Build Factory was building for Haiku & not R5 (ie: you may have got the Haiku version of the driver for the rtl8139).

Quote:

how can I check for IRQ sharing? There aren't any other Ethernet devices listed in Devices, but who knows.

Well, actually IRQ sharing may be OK, I noticed my 8139 is sharing with the USB controller. (You go through Preferences -> Devices & look at the IRQs being used by each device (scroll down the list), also you click on Ethernet & at the bottom click on Resource Conflicts. Also on Info tab, do you see the Vendor Name, Card ID & Current State - Enabled?).

After entering in a static ip (in Network Preferences). You can type in ifconfig in Terminal & your static ip should show up as inet addr: xxx.xxx.xxx.xx (ie: 192.168.111.35)

If you have an inet addr (static ip) then you can try to ping the router. If inet addr is 0.0.0.0, then you can't get an ip address for one reason or another. (ie: network card not working right).

Seems you were close, but it could just be the motherboard too. So trying it out on another system is a good idea.

Re: OK, Using Another System May Bring You Success

I know it's been more than a month, but I'd like to give you an update...

I recently tried out Haiku on the machine, and lo and behold, it networked fine. Not only was I able to ping my router, DNS worked, and I was able to surf with Net+. And, it just worked unlike in R5. ;)